import Foundation
let pattern = #"((frok |dork )*)(\w+) is (\d+) Foo"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
frok dork dumb is 10 Foo
frok dork is 10 Foo
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)