const regex = /, ([A-Z.]{12})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(', ([A-Z.]{12})', 'g')
const str = `ADDRESS.CITY || ', UK''s', ADDRESS.CITY || ', US''s', ADDRESS.CITY || ', UK''s'`;
const subst = `\n \1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);