re = /, ([A-Z.]{12})/
str = 'ADDRESS.CITY || \', UK\'\'s\', ADDRESS.CITY || \', US\'\'s\', ADDRESS.CITY || \', UK\'\'s\''
subst = '\\n \\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result