use strict;
my $str = 'ADDRESS.CITY || \', UK\'\'s\', ADDRESS.CITY || \', US\'\'s\', ADDRESS.CITY || \', UK\'\'s\'';
my $regex = qr/, ([A-Z.]{12})/p;
my $subst = '\\n \\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";