import re
regex = re.compile(r", ([A-Z.]{12})")
test_str = "ADDRESS.CITY || ', UK''s', ADDRESS.CITY || ', US''s', ADDRESS.CITY || ', UK''s'"
subst = "\\n \\1"
result = regex.sub(subst, test_str)
if result:
print(result)