#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\s+\(([a-zA-Z\d]+-){4}[a-zA-Z\d]+\)"
Local $sString = "rps-GER_TES002 (abc5051a-7d75-4d6d-9a14-ab45df3bfcdb)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")