re = /\s+\(([a-zA-Z\d]+-){4}[a-zA-Z\d]+\)/
str = 'rps-GER_TES002 (abc5051a-7d75-4d6d-9a14-ab45df3bfcdb)'
# Print the match result
str.match(re) do |match|
puts match.to_s
end