// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\s+\(([a-zA-Z\d]+-){4}[a-zA-Z\d]+\)").unwrap();
let string = "rps-GER_TES002 (abc5051a-7d75-4d6d-9a14-ab45df3bfcdb)";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}