use strict;
my $str = 'rps-GER_TES002 (abc5051a-7d75-4d6d-9a14-ab45df3bfcdb)';
my $regex = qr/\s+\(([a-zA-Z\d]+-){4}[a-zA-Z\d]+\)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}