$re = '/\s+\(([a-zA-Z\d]+-){4}[a-zA-Z\d]+\)/';
$str = 'rps-GER_TES002 (abc5051a-7d75-4d6d-9a14-ab45df3bfcdb)';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);