using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s+\(([a-zA-Z\d]+-){4}[a-zA-Z\d]+\)";
string input = @"rps-GER_TES002 (abc5051a-7d75-4d6d-9a14-ab45df3bfcdb)";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}