import Foundation
let pattern = #"\s+\(([a-zA-Z\d]+-){4}[a-zA-Z\d]+\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"rps-GER_TES002 (abc5051a-7d75-4d6d-9a14-ab45df3bfcdb)"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}