#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[0-9]{14}$"
Local $sString = "+21234567891" & @CRLF & _
"012345678913" & @CRLF & _
"+01234567891" & @CRLF & _
"0212 3456 7891" & @CRLF & _
"(+034) 1234 9132 0212" & @CRLF & _
"034 567 8910 1212" & @CRLF & _
"034 567 8912 1234" & @CRLF & _
"+1 230 4567 7894 " & @CRLF & _
"+44 123 3456 3445 " & @CRLF & _
"+21 234 5678 9134" & @CRLF & _
"9999999999999" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")