// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[0-9]{14}$").unwrap();
let string = "+21234567891
012345678913
+01234567891
0212 3456 7891
(+034) 1234 9132 0212
034 567 8910 1212
034 567 8912 1234
+1 230 4567 7894
+44 123 3456 3445
+21 234 5678 9134
9999999999999
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}