import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[0-9]{14}$";
final String string = "+21234567891\n"
+ "012345678913\n"
+ "+01234567891\n"
+ "0212 3456 7891\n"
+ "(+034) 1234 9132 0212\n"
+ "034 567 8910 1212\n"
+ "034 567 8912 1234\n"
+ "+1 230 4567 7894 \n"
+ "+44 123 3456 3445 \n"
+ "+21 234 5678 9134\n"
+ "9999999999999\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}