$re = '/^[0-9]{14}$/m';
$str = '+21234567891
012345678913
+01234567891
0212 3456 7891
(+034) 1234 9132 0212
034 567 8910 1212
034 567 8912 1234
+1 230 4567 7894
+44 123 3456 3445
+21 234 5678 9134
9999999999999
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);