using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[0-9]{14}$";
string input = @"+21234567891
012345678913
+01234567891
0212 3456 7891
(+034) 1234 9132 0212
034 567 8910 1212
034 567 8912 1234
+1 230 4567 7894
+44 123 3456 3445
+21 234 5678 9134
9999999999999
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}