use strict;
my $str = '+21234567891
012345678913
+01234567891
0212 3456 7891
(+034) 1234 9132 0212
034 567 8910 1212
034 567 8912 1234
+1 230 4567 7894
+44 123 3456 3445
+21 234 5678 9134
9999999999999
';
my $regex = qr/^[0-9]{14}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}