#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = " *(?=\d)"
Local $sString = " 11 BELIZE" & @CRLF & _
" 10 TONGA" & @CRLF & _
" 10 CONGO DEM. REP." & @CRLF & _
" 10 BHUTAN" & @CRLF & _
" 10 ANGOLA" & @CRLF & _
" 9 MALDIVES" & @CRLF & _
" 9 COOK ISLANDS" & @CRLF & _
" 9 CAYMAN ISLANDS"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")