use strict;
my $str = ' 11 BELIZE
10 TONGA
10 CONGO DEM. REP.
10 BHUTAN
10 ANGOLA
9 MALDIVES
9 COOK ISLANDS
9 CAYMAN ISLANDS';
my $regex = qr/ *(?=\d)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}