using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" *(?=\d)";
string input = @" 11 BELIZE
10 TONGA
10 CONGO DEM. REP.
10 BHUTAN
10 ANGOLA
9 MALDIVES
9 COOK ISLANDS
9 CAYMAN ISLANDS";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}