import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = " *(?=\\d)";
final String string = " 11 BELIZE\n"
+ " 10 TONGA\n"
+ " 10 CONGO DEM. REP.\n"
+ " 10 BHUTAN\n"
+ " 10 ANGOLA\n"
+ " 9 MALDIVES\n"
+ " 9 COOK ISLANDS\n"
+ " 9 CAYMAN ISLANDS";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}