re = / *(?=\d)/
str = ' 11 BELIZE
10 TONGA
10 CONGO DEM. REP.
10 BHUTAN
10 ANGOLA
9 MALDIVES
9 COOK ISLANDS
9 CAYMAN ISLANDS'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end