const regex = / *(?=\d)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(' *(?=\\d)', 'g')
const str = ` 11 BELIZE
10 TONGA
10 CONGO DEM. REP.
10 BHUTAN
10 ANGOLA
9 MALDIVES
9 COOK ISLANDS
9 CAYMAN ISLANDS`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}