#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=(^(.*)[ ])(?=#[ a-z0-9]+))|(?=(^(.*))+)"
Local $sString = "bar" & @CRLF & _
"fdsfsf345#3gt#$%3^#$T$#tr43r43" & @CRLF & _
"test spaces" & @CRLF & _
""test spaces"" & @CRLF & _
""fdsfsf345#3gt#$%3^#$T$#tr43r43" #comment" & @CRLF & _
"test spaces" #comment" & @CRLF & _
"bar" & @CRLF & _
"""" & @CRLF & _
"""""" & @CRLF & _
"foo1 #comment2" & @CRLF & _
""with space value" #comment" & @CRLF & _
"'with quote value'" & @CRLF & _
"somestringstart" & @CRLF & _
"with spaces" # a comment" & @CRLF & _
"bar"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")