using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=(^(.*)[ ])(?=#[ a-z0-9]+))|(?=(^(.*))+)";
string input = @"bar
fdsfsf345#3gt#$%3^#$T$#tr43r43
test spaces
""test spaces""
""fdsfsf345#3gt#$%3^#$T$#tr43r43"" #comment
test spaces"" #comment
bar
""
""""
foo1 #comment2
""with space value"" #comment
'with quote value'
somestringstart
with spaces"" # a comment
bar";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}