const regex = /(?=(^(.*)[ ])(?=#[ a-z0-9]+))|(?=(^(.*))+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=(^(.*)[ ])(?=#[ a-z0-9]+))|(?=(^(.*))+)', 'gm')
const str = `bar
fdsfsf345#3gt#\$%3^#\$T\$#tr43r43
test spaces
"test spaces"
"fdsfsf345#3gt#\$%3^#\$T\$#tr43r43" #comment
test spaces" #comment
bar
""
""""
foo1 #comment2
"with space value" #comment
'with quote value'
somestringstart
with spaces" # a comment
bar`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}