$re = '/(?=(^(.*)[ ])(?=#[ a-z0-9]+))|(?=(^(.*))+)/m';
$str = 'bar
fdsfsf345#3gt#$%3^#$T$#tr43r43
test spaces
"test spaces"
"fdsfsf345#3gt#$%3^#$T$#tr43r43" #comment
test spaces" #comment
bar
""
""""
foo1 #comment2
"with space value" #comment
\'with quote value\'
somestringstart
with spaces" # a comment
bar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);