import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=(^(.*)[ ])(?=#[ a-z0-9]+))|(?=(^(.*))+)";
final String string = "bar\n"
+ "fdsfsf345#3gt#$%3^#$T$#tr43r43\n"
+ "test spaces\n"
+ "\"test spaces\"\n"
+ "\"fdsfsf345#3gt#$%3^#$T$#tr43r43\" #comment\n"
+ "test spaces\" #comment\n"
+ "bar\n"
+ "\"\"\n"
+ "\"\"\"\"\n"
+ "foo1 #comment2\n"
+ "\"with space value\" #comment\n"
+ "'with quote value'\n"
+ "somestringstart\n"
+ "with spaces\" # a comment\n"
+ "bar";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}