use strict;
my $str = 'bar
fdsfsf345#3gt#$%3^#$T$#tr43r43
test spaces
"test spaces"
"fdsfsf345#3gt#$%3^#$T$#tr43r43" #comment
test spaces" #comment
bar
""
""""
foo1 #comment2
"with space value" #comment
\'with quote value\'
somestringstart
with spaces" # a comment
bar';
my $regex = qr/(?=(^(.*)[ ])(?=#[ a-z0-9]+))|(?=(^(.*))+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}