#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(from .*\]\)\n\t)"
Local $sString = "Received: from respo.mysite.ru (snd1.mysite.ru [172.11.1.111])" & @CRLF & _
" by snd1.mysite.ru.ru (Postfix) with ESMTP id BDB6AC45A2" & @CRLF & _
" for <vsevolod.xxxxxx90@mail.ru>; Tue, 18 Oct 2016 20:48:01 +0200 (CEST)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")