$re = '/(from .*\]\)\n\t)/';
$str = 'Received: from respo.mysite.ru (snd1.mysite.ru [172.11.1.111])
by snd1.mysite.ru.ru (Postfix) with ESMTP id BDB6AC45A2
for <vsevolod.xxxxxx90@mail.ru>; Tue, 18 Oct 2016 20:48:01 +0200 (CEST)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);