const regex = /(from .*\]\)\n\t)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(from .*\\]\\)\\n\\t)', 'g')
const str = `Received: from respo.mysite.ru (snd1.mysite.ru [172.11.1.111])
by snd1.mysite.ru.ru (Postfix) with ESMTP id BDB6AC45A2
for <vsevolod.xxxxxx90@mail.ru>; Tue, 18 Oct 2016 20:48:01 +0200 (CEST)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}