// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(from .*\]\)\n\t)").unwrap();
let string = "Received: from respo.mysite.ru (snd1.mysite.ru [172.11.1.111])
by snd1.mysite.ru.ru (Postfix) with ESMTP id BDB6AC45A2
for <vsevolod.xxxxxx90@mail.ru>; Tue, 18 Oct 2016 20:48:01 +0200 (CEST)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}