import Foundation
let pattern = #"(from .*\]\)\n\t)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Received: from respo.mysite.ru (snd1.mysite.ru [172.11.1.111])
by snd1.mysite.ru.ru (Postfix) with ESMTP id BDB6AC45A2
for <vsevolod.xxxxxx90@mail.ru>; Tue, 18 Oct 2016 20:48:01 +0200 (CEST)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)