using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(from .*\]\)\n\t)";
string input = @"Received: from respo.mysite.ru (snd1.mysite.ru [172.11.1.111])
by snd1.mysite.ru.ru (Postfix) with ESMTP id BDB6AC45A2
for <vsevolod.xxxxxx90@mail.ru>; Tue, 18 Oct 2016 20:48:01 +0200 (CEST)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}