package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(from .*\]\)\n\t)`)
var str = `Received: from respo.mysite.ru (snd1.mysite.ru [172.11.1.111])
by snd1.mysite.ru.ru (Postfix) with ESMTP id BDB6AC45A2
for <vsevolod.xxxxxx90@mail.ru>; Tue, 18 Oct 2016 20:48:01 +0200 (CEST)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}