#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?:(?<![\{\}])[\n]|([\{\}\;])(\n)|\b\s\B|\B\s\b|\B\s\B)"
Local $sString = "function main(){" & @CRLF & _
" var a = 'hello'" & @CRLF & _
" console.log(a)" & @CRLF & _
" return 1;" & @CRLF & _
"}"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)