const regex = /(?:(?<![\{\}])[\n]|([\{\}\;])(\n)|\b\s\B|\B\s\b|\B\s\B)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?<![\\{\\}])[\\n]|([\\{\\}\\;])(\\n)|\\b\\s\\B|\\B\\s\\b|\\B\\s\\B)', 'g')
const str = `function main(){
var a = 'hello'
console.log(a)
return 1;
}`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);