import Foundation
let pattern = #"(?:(?<![\{\}])[\n]|([\{\}\;])(\n)|\b\s\B|\B\s\b|\B\s\B)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
function main(){
var a = 'hello'
console.log(a)
return 1;
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)