using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?<![\{\}])[\n]|([\{\}\;])(\n)|\b\s\B|\B\s\b|\B\s\B)";
string substitution = @"";
string input = @"function main(){
var a = 'hello'
console.log(a)
return 1;
}";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}