use strict;
my $str = 'function main(){
var a = \'hello\'
console.log(a)
return 1;
}';
my $regex = qr/(?:(?<![\{\}])[\n]|([\{\}\;])(\n)|\b\s\B|\B\s\b|\B\s\B)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";