import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?<![\\{\\}])[\\n]|([\\{\\}\\;])(\\n)|\\b\\s\\B|\\B\\s\\b|\\B\\s\\B)";
final String string = "function main(){\n"
+ " var a = 'hello'\n"
+ " console.log(a)\n"
+ " return 1;\n"
+ "}";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}