re = /(?:(?<![\{\}])[\n]|([\{\}\;])(\n)|\b\s\B|\B\s\b|\B\s\B)/
str = 'function main(){
var a = \'hello\'
console.log(a)
return 1;
}'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result