# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!") and/" and/g;t' <<< "and purpose=\"Buy and property_type=\"Home\" and property_nature=\"Residential and city =\" Lahore\""