use strict;
my $str = 'and purpose="Buy and property_type="Home" and property_nature="Residential and city =" Lahore"';
my $regex = qr/(?<!") and/p;
my $subst = '" and';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";