re = /(?<!") and/
str = 'and purpose="Buy and property_type="Home" and property_nature="Residential and city =" Lahore"'
subst = '" and'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result