#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?<!") and"
Local $sString = "and purpose="Buy and property_type="Home" and property_nature="Residential and city =" Lahore""
Local $sSubst = "" and"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)