import Foundation
let pattern = #"(?<!") and"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"and purpose="Buy and property_type="Home" and property_nature="Residential and city =" Lahore""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"" and"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)