const regex = /(?<!") and/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!") and', 'g')
const str = `and purpose="Buy and property_type="Home" and property_nature="Residential and city =" Lahore"`;
const subst = `" and`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);